Hi, there! I'm new to this forum, and i'm not sure if here is the correct place to post this... please tell me if i was wrong. I'm currentry working on BigBrother plugin to implement inventory related features. I think there are lot of problem about PlayerInventory class for pc users because of the difference of hotbar implementation between PC and PE. So, I tried to create new DesktopPlayerInventory class which extends PlayerInventory in BigBrother plugin. Because some code manipulate the inventory via PlayerInventory#inventory member variable or PlayerInventory#getInventory() method. I think there are many plugin which manipulate inventory through this API too. So, i want to make newly created DesktopPlayerInventory class compatible with those existing code. So I wrote a patch for BigBrotherPlugin to instantiate DesktopPlayerInventory class and initialize it. Please see patch below. https://github.com/eternalharvest/B...e7dd689#diff-7c176b9f07b8ceb0fe9b6e67a6a7d019 I copied Human#initEntity() method from PMMP, and modify it (original code is commented out) because I want to instantiate DesktopPlayerInventory class instead of PlayerInventory class. But i think this method is too big, and it has parent::initEntity() call, so i need to call Living::initEntity() instead (but i think it is dangerous). And it seems Human#initEntity() method is updated frequently, so I don't want to copy and paste it. So, I wish the Human#initEntity() is devided into several part of method. For example, I'm happy if Human#initInventory() method is added. It's very simple solution but i'm not sure whether these kind of changes are acceptable or not. And i'm not sure if my approach to extends PlayerInventory is correct. Thank you for taking the time And I appreciate any help.