Why don't you name the api version to the bedrock version you are referring to?

Discussion in 'Requests' started by elvamo, Mar 24, 2020.

  1. elvamo

    elvamo Spider

    Messages:
    7
    en-US:
    As the title says, if it is api 9.9.x that refers to bedrock 1.16.X why does it not happen to api 1.16.x I just arrived and I do not know that we complete download for which version I have spent a whole day trying to see what api is for version 1.14.30 but I can't find anything.
    Im tolking PocketMine-MP not Plugins

    es-ES:
    Como dice el titulo, si es api 9.9.x la que se refiere a bedrock 1.16.X por que no pasa a api 1.16.x acabo de llegar y no se que completemos bajar para que versión llevo un día entero intentado ver que api es para la versión 1.14.30 pero no encuentro nada. Esoy hablando sobre PocketMine-MP no los plugins.
     
    Last edited: Mar 25, 2020
  2. HimbeersaftLP

    HimbeersaftLP Fish

    Messages:
    2,078
    GitHub:
    HimbeersaftLP
  3. elvamo

    elvamo Spider

    Messages:
    7
    US:
    What does that have to do with even if it is a modified version you can put the version number in which you are based on PS3 pirate the CFW versions
    (Custom FirmWare (modified)) use the same version number as the FW (FirmWare (original)) example the rebug team if they are and this is version 4.85 rebug 4.85 comes out and if they have to update Rebug comes out 4.85 rev X your comment it lacks a lodge.

    ES:
    Que tiene que ver eso que has puesto de aunque sea una version modificada puedes poner el numero de version en la que estas basado en PS3 pirata las versiones CFW
    (Custom FirmWare (modificadas)) ysan el mismo numero de version que las FW (FirmWare (originales)) ejemplo el team rebug si sony esta ne la version 4.85 sale la rebug 4.85 y si tienen que avctualiazar sale la Rebug 4.85 rev x tu comentario carece de logia.
     
  4. HimbeersaftLP

    HimbeersaftLP Fish

    Messages:
    2,078
    GitHub:
    HimbeersaftLP
    WTF are you on about?!
    It's an API version, it's about the compatibility with plugins and is changed according to semver guidelines.
    Because if the API version changed with the Minecraft version, plugins for older version of Minecraft wouldn't work, even if the server's API didn't change which would be stupid as hell.
     
  5. dktapps

    dktapps Administrator Staff Member PMMP Team

    Messages:
    768
    GitHub:
    dktapps
    Changes to the server aren't exclusively locked to MCPE changes. The core version system is unrelated to the MCPE version.
     
    HimbeersaftLP likes this.
  6. elvamo

    elvamo Spider

    Messages:
    7
    If I understand that, I say that it is so that the user can better identify if our work is related ABOUT version 1.14, for example, now I have seen version 3.11.5 and 3.11.6. It is easy for a person to believe that it is the versions 1.15 and 1.16 bedrock that are already in beta to use would be more intuitive for the user is to know that the api if renamed to 1.14.0 rev 56 is that it refers to the version of minecraft 1.14 and is the rev 56 would be your changes It does not matter whether it is an api or a full version of 0, of course the changes are what you want. It is just an idea so that the user at a glance knows what version you are trying in each api, more intuitively without having to be looking for what api is each version if I want to download the version of minecraft 1.11? that api is 3.0.0 and 1.12 is api 3.1.0 I think it is more messy but good.
     
  7. elvamo

    elvamo Spider

    Messages:
    7
    It does not matter the version is a NUMBER, the important thing is the complement code that serves only to identify that version 1 is older than version 2 and I have programmed some program for computer and ps3 and to help the user name the versions according to The version of play that made significant changes if ps3 was in version 3.50 would release the program in 3.50 and it would be version 1 of the program, but so the user knows which program is for each version, so sony removed 4.00 and I would remove the app in version 4.00 and in truth it is the 2.00 version if you wanted to get a version with more functions and sony drought in the 4.00 so it removes the 4.00.x or 4.00 rev x and everyone knows that if you were in the 3.50 none of the 4.00 would work for you who have to Investigating having the api 3 which versions are compatible is merely making the user more intuitive. In fact, sometimes Sony changed from version 4.00 to 4.85. I took out the app without changing a single line of code, only version 4.85. and it played nothing and for the user it is easier than that.
     
  8. wolfdale

    wolfdale Zombie

    Messages:
    396
    HimbeersaftLP likes this.
  9. yuko fuyutsuki

    yuko fuyutsuki Witch

    Messages:
    74
    GitHub:
    fuyutsuki
    PMMP is not fully compatible with Minecraft changes. Versioning like you say (Sony's example) only causes confusion and hassle for many plugins (like the previous 3.0.0-ALPHAx versioning).
     
    HimbeersaftLP and ethaniccc like this.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.