Solved Incompatible API version

Discussion in 'Help' started by CuddlesTheCatMC, Dec 11, 2018.

  1. CuddlesTheCatMC

    CuddlesTheCatMC Witch

    Messages:
    58
    GitHub:
    cuddlesthecatmc
    Hello everyone, i'm new here and i'm new on setting up pocketmine-mp server.
    Can you guys help me about my problem? I really need help. My problem is, i downloaded a plugin on poggit and i put on my pm folder and on the plugins folder and i restarted my pmmp server. I red the console and it says ex. "incompatible api version" Custom Alerts (plugin requires one of: 3.0.0) how can i fix that problem? *And my pm version is 4.0.0 and bedrock mcpe version is 1.7.0.* It didn't work on all of my plugins and i repeated the actions i did but, it doesnt work. Always says incompatible.. please help me guys ☺ Advance thank you and Merry christmas to the person who can help me with this!
     
  2. A354-PH

    A354-PH Baby Zombie

    Messages:
    177
    GitHub:
    A354-PH
    You need to have PocketMine-MP phar with API 3.0.0
     
    jasonwynn10 and CuddlesTheCatMC like this.
  3. CuddlesTheCatMC

    CuddlesTheCatMC Witch

    Messages:
    58
    GitHub:
    cuddlesthecatmc
    Where can i get that pm with phar 3.0.0? Pls do send the link if ever
     
  4. dktapps

    dktapps Administrator Staff Member PMMP Team

    Messages:
    742
    GitHub:
    dktapps
  5. CuddlesTheCatMC

    CuddlesTheCatMC Witch

    Messages:
    58
    GitHub:
    cuddlesthecatmc
    So i downloaded the file in the link that you sent to me, after that what will i do in that file?
     
  6. Destroyer57

    Destroyer57 Zombie

    Messages:
    265
    Replace with old PocketMine-MP.phar
     
    Last edited by a moderator: Dec 11, 2018
    CuddlesTheCatMC likes this.
  7. CuddlesTheCatMC

    CuddlesTheCatMC Witch

    Messages:
    58
    GitHub:
    cuddlesthecatmc
    Thank you so much!

    CuddlesTheCatMC

    -MARKED AS SOLVED
     
  8. SOFe

    SOFe Administrator Staff Member PMMP Team Poggit Admin

    Messages:
    1,898
    GitHub:
    sof3
    You should have permission to add the tag.
    [​IMG]
    Your permissions are a bit different from mine, but you should have the "Edit Thread" button too.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.