Windows 10 Editon can't join my server

Discussion in 'Help' started by Jules, Feb 8, 2019.

  1. Jules

    Jules Witch

    Messages:
    57
    GitHub:
    Julooooos
    Good evening, I do not understand why but, the players who play on pc can not join my server. I use PocketMine-MP 3.6.1. Their games crash as soon as they join the server ... No error appears in the console.
     
  2. Muqsit

    Muqsit Wither Skeleton Verified

    Messages:
    1,458
    GitHub:
    muqsit
    Can you run /pl and send the output of the command. I assume it's a faulty plugin.
     
  3. Jules

    Jules Witch

    Messages:
    57
    GitHub:
    Julooooos
    I just use PureChat, PurePerms and EconomyAPI, the rest I manage it in my core.
     
  4. dktapps

    dktapps Administrator Staff Member PMMP Team

    Messages:
    693
    GitHub:
    dktapps
    IP/port?
     
  5. Jules

    Jules Witch

    Messages:
    57
    GitHub:
    Julooooos
    play-gladiators.fr
    19132
     
    Last edited: Feb 11, 2019 at 9:06 AM
  6. Jules

    Jules Witch

    Messages:
    57
    GitHub:
    Julooooos
    did you find the bug?
     
  7. dktapps

    dktapps Administrator Staff Member PMMP Team

    Messages:
    693
    GitHub:
    dktapps
    I haven't had a chance to investigate it yet.
     
  8. Jules

    Jules Witch

    Messages:
    57
    GitHub:
    Julooooos
    ok tell me when you found the bug
     
  9. dktapps

    dktapps Administrator Staff Member PMMP Team

    Messages:
    693
    GitHub:
    dktapps
    I don't seem to be crashing when I connect. Need more information.
     
  10. Jules

    Jules Witch

    Messages:
    57
    GitHub:
    Julooooos
    hum weird
     
  11. Jules

    Jules Witch

    Messages:
    57
    GitHub:
    Julooooos
    It doesn’t work for me and other players that are on w10...
     
  12. Jules

    Jules Witch

    Messages:
    57
    GitHub:
    Julooooos
    It just work for you.
     
  13. Jules

    Jules Witch

    Messages:
    57
    GitHub:
    Julooooos
    sometimes this error appears in the console:

    2019-02-09 [10:42:21] [Server / INFO thread]: [/86.195.155.221:59119] disconnected due to incompatible protocol version (313)

    Is it possible that it is a report with this bug?
     
  14. Muqsit

    Muqsit Wither Skeleton Verified

    Messages:
    1,458
    GitHub:
    muqsit
    That's the MCPE 1.8 protocol. It just means your server doesn't support 1.8 and so they weren't able to join your server.
     
  15. Jules

    Jules Witch

    Messages:
    57
    GitHub:
    Julooooos
    My server is running 1.9
    PocketMine-MP 3.6.1
     
    Last edited: Feb 9, 2019
  16. Jules

    Jules Witch

    Messages:
    57
    GitHub:
    Julooooos
  17. jasonwynn10

    jasonwynn10 Wither Skeleton Poggit Reviewer Verified

    Messages:
    1,283
    GitHub:
    jasonwynn10
  18. Edwardthedog2

    Edwardthedog2 Skeleton Verified

    Messages:
    858
    GitHub:
    edwardthedog2
    Well then that's why your players can't join your server.. Their trying to connect with outdated clients. Server versions aren't backwards-compatible like that.
     
  19. Jules

    Jules Witch

    Messages:
    57
    GitHub:
    Julooooos
    So, what can I do to fix this problem?
     
  20. Edwardthedog2

    Edwardthedog2 Skeleton Verified

    Messages:
    858
    GitHub:
    edwardthedog2
    Tell the players to update their game. If the majority of your player base prefers to stay with 1.8, than you could use an older version of PocketMine (made for 1.8) to follow suit.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.