1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[NEED HELP] PMMP don't start problems in CentOS (Linux)

Discussion in 'Help' started by commonplayz, Jan 11, 2017.

  1. commonplayz

    commonplayz Spider

    Messages:
    14
    GitHub:
    commonplayz
    Hello guys,

    i need help, because i've installed pmmp on a centos server but everytime when i do ./start.sh then comes "Couldn't find a working PHP 7 binary, please use the installer." but i have PHP7 in the server in the right directory but there come everytime that they dont found the binary can anyone help me thanks :D

    -Sorry for my bad english and thanks to everyone who helps me :D
     
  2. HittmanA

    HittmanA Baby Zombie

    Messages:
    150
    GitHub:
    hittmana
    Is there an install.sh file?
     
    commonplayz likes this.
  3. commonplayz

    commonplayz Spider

    Messages:
    14
    GitHub:
    commonplayz
    No, there are only a compile.sh but not a install.sh
     
  4. Edwardthedog2

    Edwardthedog2 Zombie Verified

    Messages:
    369
    GitHub:
    edwardthedog2
    The only thing I can think of is to try deleting your current PHP binary and reinstalling PocketMine. Where did you get the PHP binary that you have?
     
    commonplayz likes this.
  5. commonplayz

    commonplayz Spider

    Messages:
    14
    GitHub:
    commonplayz
    I have it from bintary and that doesnt work
     
  6. commonplayz

    commonplayz Spider

    Messages:
    14
    GitHub:
    commonplayz
    Now there comes this:

    "
    ./bin/php7/bin/php: /lib64/libm.so.6: version `GLIBC_2.15' not found (required by ./bin/php7/bin/php)
    ./bin/php7/bin/php: /lib64/libc.so.6: version `GLIBC_2.15' not found (required by ./bin/php7/bin/php)
    ./bin/php7/bin/php: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by ./bin/php7/bin/php)
    ./bin/php7/bin/php: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /home/mcpe/bin/php7/bin/../lib/libz.so.1)
    ./bin/php7/bin/php: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /home/mcpe/bin/php7/bin/../lib/libyaml-0.so.2)
    ./bin/php7/bin/php: /lib64/libm.so.6: version `GLIBC_2.15' not found (required by /home/mcpe/bin/php7/bin/../lib/libpng16.so.16)
    ./bin/php7/bin/php: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /home/mcpe/bin/php7/bin/../lib/libpng16.so.16)
    ./bin/php7/bin/php: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /home/mcpe/bin/php7/bin/../lib/libcurl.so.4)
    ./bin/php7/bin/php: /lib64/libc.so.6: version `GLIBC_2.16' not found (required by /home/mcpe/bin/php7/bin/../lib/libcurl.so.4)
    ./bin/php7/bin/php: /lib64/libc.so.6: version `GLIBC_2.15' not found (required by /home/mcpe/bin/php7/bin/../lib/libcurl.so.4)
    ./bin/php7/bin/php: /lib64/libc.so.6: version `GLIBC_2.17' not found (required by /home/mcpe/bin/php7/bin/../lib/libcurl.so.4)
    "
     
  7. HimbeersaftLP

    HimbeersaftLP Zombie Pigman

    Messages:
    674
    GitHub:
    HimbeersaftLP
    Try
    Code:
    yum install gcc
     
    commonplayz likes this.
  8. commonplayz

    commonplayz Spider

    Messages:
    14
    GitHub:
    commonplayz
    I reinstall php7 many times and i tried to install lib64
    "Package gcc-4.4.7-17.el6.x86_64 already installed and latest version"
     
  9. HimbeersaftLP

    HimbeersaftLP Zombie Pigman

    Messages:
    674
    GitHub:
    HimbeersaftLP
    An what about gcc-multilib
     
    commonplayz likes this.
  10. commonplayz

    commonplayz Spider

    Messages:
    14
    GitHub:
    commonplayz
    Package gcc-c++-4.4.7-17.el6.x86_64 already installed and latest version

    Das ist auch schon drauf auf der aktuellsten version :(
     
  11. Thunder33345

    Thunder33345 Wither Skeleton Verified

    Messages:
    1,139
    GitHub:
    Thunder33345
    Edwardthedog2 and commonplayz like this.
  12. commonplayz

    commonplayz Spider

    Messages:
    14
    GitHub:
    commonplayz
    I tried it with that but its not working again!
    "./bin/php7/bin/php: /lib64/libm.so.6: version `GLIBC_2.15' not found (required by ./bin/php7/bin/php)
    ./bin/php7/bin/php: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by ./bin/php7/bin/php)
    ./bin/php7/bin/php: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /home/mcpe/bin/php7/bin/../lib/libz.so.1)
    ./bin/php7/bin/php: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /home/mcpe/bin/php7/bin/../lib/libyaml-0.so.2)
    ./bin/php7/bin/php: /lib64/libm.so.6: version `GLIBC_2.15' not found (required by /home/mcpe/bin/php7/bin/../lib/libpng16.so.16)
    ./bin/php7/bin/php: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /home/mcpe/bin/php7/bin/../lib/libpng16.so.16)
    ./bin/php7/bin/php: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /home/mcpe/bin/php7/bin/../lib/libcurl.so.4)
    ./bin/php7/bin/php: /lib64/libc.so.6: version `GLIBC_2.17' not found (required by /home/mcpe/bin/php7/bin/../lib/libcurl.so.4)
    "
     
  13. commonplayz

    commonplayz Spider

    Messages:
    14
    GitHub:
    commonplayz
    I found the problem it's because the OS i reinstall Debian 8 and with that its working and thanks to everyone who helped me
     
  14. HimbeersaftLP

    HimbeersaftLP Zombie Pigman

    Messages:
    674
    GitHub:
    HimbeersaftLP
    Try yum install glibc
     
  15. HimbeersaftLP

    HimbeersaftLP Zombie Pigman

    Messages:
    674
    GitHub:
    HimbeersaftLP
    I could've told you that it's easier on Debian :p
     
    commonplayz likes this.
  16. Awzaw

    Awzaw Zombie Verified

    Messages:
    352
    GitHub:
    awzaw
    Which version of CentOS are you using? If it isn't 7 then updating should fix the issue
     
    HimbeersaftLP and commonplayz like this.

Share This Page