Installtion on MacOS not working

Discussion in 'Help' started by ryansg8, Jun 30, 2019.

  1. ryansg8

    ryansg8 Creeper

    Messages:
    4
    Hi,
    I have tried to use the automated installation for MacOS and when it installs it says error, please install automake, cmake, GNU libtool, autoconf.
    When I try to run the start.sh with ./start.sh it gives this back in terminal:

    dyld: Library not loaded: /usr/local/opt/libidn2/lib/libidn2.0.dylib

    Referenced from: /Users/ryan/PocketMine/bin/php7/bin/php

    Reason: image not found

    Abort trap: 6

    Any help would be appreciated.
     
    StuntzCo likes this.
  2. StuntzCo

    StuntzCo Baby Zombie

    Messages:
    197
    Hi guys, I took my server down around a year and a half ago and since then I got a new computer downloaded mcpe and decided its time to build a server again. anyways long story short I've run into the exact same issue also side note I want to make sure I'm installing a version of pocketmine that will work with mcpe v1.12.0
     
  3. ryansg8

    ryansg8 Creeper

    Messages:
    4
    Never found a solution, tried downloading everything I wanted, still didnt work. Went to Nukkit instead and worked fine with no issues.
     
  4. StuntzCo

    StuntzCo Baby Zombie

    Messages:
    197
    Looking back when I first installed pocketmine which was like almost two years ago my biggest frustration was always how poorly they explained installation and how slow they were to respond and help with errors but its still a great tool and i hope to use it my solution was to make videos on how to install but at this point im having to relearn everything and im running into errors along the way. does Nukkit have better documentation and installation guides
     
  5. StuntzCo

    StuntzCo Baby Zombie

    Messages:
    197
    I would greatly appreciate if someone could find a solution to the original problem soon because I really love the pm community and the work they have put into this awesome software and all its plugins but its only useful to me if I can get it to run again otherwise I might have to resort to nukkit which i really don't want to but I'm on a time crunch
     
  6. ryansg8

    ryansg8 Creeper

    Messages:
    4
    Hey sorry, all I know is that Nukkit is a java port of pocketmine, and that it worked fine on my mac unlike pcoketmine.
     
  7. StuntzCo

    StuntzCo Baby Zombie

    Messages:
    197
    I may have found a solution https://forums.pmmp.io/posts/61140/ but im gonna test it first
     
    ryansg8 likes this.
  8. ryansg8

    ryansg8 Creeper

    Messages:
    4
    Awesome please report back if it works, I would prefer pocketmine as it has more plugins
     
  9. StuntzCo

    StuntzCo Baby Zombie

    Messages:
    197
    Okay I have finally wrapped my head around the problem but have yet to solve it basically the problem is php not being up to date but I’m running on a MacBook Pro 2019 with Mojave and with that version of OS X I’m running into lots of trouble trying to upgrade php to 7.2 I think it is anyways I’ll work on it some more tonight no guarantees though
     
  10. StuntzCo

    StuntzCo Baby Zombie

    Messages:
    197
    Also it’s not hard to install automake cmake and gnu library just search it yourself there’s tons of solutions to install them the problem is on my Mac the reason it needs those tools is to compile the php so if your up to date then those aren’t even really needed but for me even after they installed pm is still unable to compile it and it has something to do with my operating system
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.