Cant join my own server!

Discussion in 'Help' started by JellyBelly339, Oct 9, 2018.

  1. JellyBelly339

    JellyBelly339 Silverfish

    Messages:
    15
    GitHub:
    z0mbieslayer
    I have made my server and everything in the console is fine! I have used pocketmine before but that was when the server showed up in local. I have tried putting in my IPv4 address into mcpe but it doesnt connect. Please help! If you need more info, just ask!
     
  2. notdrewdev

    notdrewdev Spider Jockey

    Messages:
    30
    GitHub:
    drewsucksatlife
    have you tried turning it off and on?
     
  3. Edwardthedog2

    Edwardthedog2 Skeleton Verified

    Messages:
    868
    GitHub:
    edwardthedog2
    What error message do you get?
     
  4. JellyBelly339

    JellyBelly339 Silverfish

    Messages:
    15
    GitHub:
    z0mbieslayer
    I dont get an error message. I just cant join the server, whether i use my internal or external ip.
     
  5. Pugzy

    Pugzy Creeper

    Messages:
    2
    GitHub:
    pugzy
  6. JellyBelly339

    JellyBelly339 Silverfish

    Messages:
    15
    GitHub:
    z0mbieslayer
  7. Aericio

    Aericio Slime

    Messages:
    99
    GitHub:
    aericio
    First, ensure that UDP port 19132 is allowed for PocketMine-MP on the firewall for your Window 7 machine.
    Second, ensure that you are typing in the correct local IP address for your computer. (check via ipconfig on command prompt or on your router)
    Third, ensure that you are on the same network as your computer
    If nothing works, you can try UPNP Forwarding or Port Forwarding and connect with your public ip address instead. It might just "work."

    or check off that holy DMZ button on your router and let everything go haywire. works 99% of the time. not recommended, though.
     
  8. Destroyer57

    Destroyer57 Baby Zombie

    Messages:
    189
    Maybe you have one of the newest routers wich only support ipv6 wich aint implemented yet for whatever reason i got the same problem
     
  9. Destroyer57

    Destroyer57 Baby Zombie

    Messages:
    189
    Dmz is too risky it opens all ports
     
  10. JellyBelly339

    JellyBelly339 Silverfish

    Messages:
    15
    GitHub:
    z0mbieslayer
    I have tried all of those and have no luck.
    I do have an option in ipconfig that says IPv6. Maybe thats the problem.
     
  11. Edwardthedog2

    Edwardthedog2 Skeleton Verified

    Messages:
    868
    GitHub:
    edwardthedog2
    Nope. MCBE (as well as Minecraft Java) don't support the ability to connect to servers with IPv6. Only IPv4. You don't need an IPv6 to connect.

    Also, what version of PocketMine do you have?
     
  12. JellyBelly339

    JellyBelly339 Silverfish

    Messages:
    15
    GitHub:
    z0mbieslayer
    I am running Pocketmine-MP 3.2.4
     
  13. Edwardthedog2

    Edwardthedog2 Skeleton Verified

    Messages:
    868
    GitHub:
    edwardthedog2
    What version of the game are you trying to connect with?
     
  14. JellyBelly339

    JellyBelly339 Silverfish

    Messages:
    15
    GitHub:
    z0mbieslayer
    Minecraft PE version 1.6.2
     
  15. GatoBinario

    GatoBinario Spider Jockey

    Messages:
    28
    Put your real IP not public
    its something like
     
  16. Destroyer57

    Destroyer57 Baby Zombie

    Messages:
    189
    If you play on windows you can disable Ipv6 but on android it needs root
     
  17. JellyBelly339

    JellyBelly339 Silverfish

    Messages:
    15
    GitHub:
    z0mbieslayer
    Sorry for late response, But i did put my real IP, still nothing.
    I'm on iOS
     
  18. GatoBinario

    GatoBinario Spider Jockey

    Messages:
    28
    Do You have the phar for your version?
     
  19. CupidonSauce173

    CupidonSauce173 Zombie

    Messages:
    234
    GitHub:
    cupidonsauce173
    did you open your ports or shutdown your firewalls ?
    if you ports are not open and you don't want to just close your firewall :

    1. Navigate to Control Panel, System and Security and Windows Firewall.
    2. Select Advanced settings and highlight Inbound Rules in the left pane.
    3. Right click Inbound Rules and select New Rule.
    4. Add the port you need to open and click Next.
    5. Add the protocol (TCP or UDP) and the port number into the next window and click Next.
    6. Select Allow the connection in the next window and hit Next.
    7. Select the network type as you see fit and click Next.
    8. Name the rule something meaningful and click Finish.
     
  20. JellyBelly339

    JellyBelly339 Silverfish

    Messages:
    15
    GitHub:
    z0mbieslayer
    I have the phar for 1.6.0 because there is no phar for 1.6.2. But that would tell me the server is outdated if i was using an outdated phar.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.